CVE-2026-106557

CVE-2026-106557 is a high-severity path traversal vulnerability in @backstage/plugin-techdocs-node (npm), affecting versions < 1.15.4. It is fixed in 1.15.4.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Backstage has improper input validation in TechDocs Markdown extension configuration

Workarounds

  • Generate TechDocs only from trusted repositories with reviewed MkDocs configuration.
  • Use isolated build environments with restricted filesystem access and network egress.
  • Prefer externally generated TechDocs with appropriately sandboxed CI.

Impact

An authenticated user who can register or modify documentation sources may cause a TechDocs build to access resources outside the intended documentation boundary. Depending on deployment configuration, this may expose sensitive backend-host data or internal network resources.

Input manipulates file paths to reach files outside the intended directory, such as configuration or credential files. Typical impact: unauthorized file read or write outside the intended directory.

CVE-2026-106557 has a CVSS score of 7.7 (High). The vector is network-reachable, low privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (1.15.4); upgrading removes the vulnerable code path.

Affected versions

@backstage/plugin-techdocs-node (< 1.15.4)

Security releases

@backstage/plugin-techdocs-node → 1.15.4 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Patched in @backstage/plugin-techdocs-node version 1.15.4.

Adopters must also use pymdown-extensions version 10.21.3 or newer, normally through mkdocs-techdocs-core version 1.7.0 or newer. @backstage/plugin-techdocs-node does not control the Python dependencies used by the generator; with an older PyMdown release, snippets may remain vulnerable to file inclusion even after their configuration is sanitized.

Frequently Asked Questions

  1. What is CVE-2026-106557? CVE-2026-106557 is a high-severity path traversal vulnerability in @backstage/plugin-techdocs-node (npm), affecting versions < 1.15.4. It is fixed in 1.15.4. Input manipulates file paths to reach files outside the intended directory, such as configuration or credential files.
  2. How severe is CVE-2026-106557? CVE-2026-106557 has a CVSS score of 7.7 (High). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of @backstage/plugin-techdocs-node are affected by CVE-2026-106557? @backstage/plugin-techdocs-node (npm) versions < 1.15.4 is affected.
  4. Is there a fix for CVE-2026-106557? Yes. CVE-2026-106557 is fixed in 1.15.4. Upgrade to this version or later.
  5. Is CVE-2026-106557 exploitable, and should I be worried? Whether CVE-2026-106557 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-106557 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-106557? Upgrade @backstage/plugin-techdocs-node to 1.15.4 or later.

Other vulnerabilities in @backstage/plugin-techdocs-node

Stop the waste.
Protect your environment with Kodem.