CVE-2026-107287

CVE-2026-107287 is a medium-severity uncontrolled resource consumption vulnerability in pydantic-ai (pip), affecting versions >= 1.77.0, < 1.107.7. It is fixed in 1.107.7, 2.52.0.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Pydantic AI: Excessive resource use when local web fetching converts nested HTML

Applications using Pydantic AI's local web-fetch tool can experience excessive CPU and memory use when it converts attacker-controlled HTML. An agent must fetch the affected page; provider-native web fetching is not affected.

Details

Nested block elements cause HTML-to-Markdown conversion to reprocess accumulated text at each level and can greatly expand the intermediate output. The response-body limit bounds downloaded bytes, while the returned-content limit is applied only after conversion. On current releases, conversion runs in a worker thread but can still consume substantial resources and delay other work in the process. Older releases performed conversion on the event loop.

Mitigation

Upgrade to a patched release of pydantic-ai or pydantic-ai-slim. If you cannot upgrade yet, avoid using local web fetching for attacker-controlled HTML.

Impact

Crafted input forces the application to consume excessive CPU, memory, or other resources, degrading or denying service. Typical impact: denial of service.

CVE-2026-107287 has a CVSS score of 6.5 (Medium). The vector is network-reachable, no privileges required, and user interaction required. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (1.107.7, 2.52.0); upgrading removes the vulnerable code path.

Affected versions

pydantic-ai (>= 1.77.0, < 1.107.7) pydantic-ai (>= 2.0.0b1, < 2.52.0) pydantic-ai-slim (>= 1.77.0, < 1.107.7) pydantic-ai-slim (>= 2.0.0b1, < 2.52.0)

Security releases

pydantic-ai → 1.107.7 (pip) pydantic-ai → 2.52.0 (pip) pydantic-ai-slim → 1.107.7 (pip) pydantic-ai-slim → 2.52.0 (pip)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade the following packages to resolve this vulnerability:

pydantic-ai to 1.107.7 or later; pydantic-ai to 2.52.0 or later; pydantic-ai-slim to 1.107.7 or later; pydantic-ai-slim to 2.52.0 or later

Kodem Kai can prioritize this vulnerability in your dependency tree and generate a fix recommendation.

Frequently Asked Questions

  1. What is CVE-2026-107287? CVE-2026-107287 is a medium-severity uncontrolled resource consumption vulnerability in pydantic-ai (pip), affecting versions >= 1.77.0, < 1.107.7. It is fixed in 1.107.7, 2.52.0. Crafted input forces the application to consume excessive CPU, memory, or other resources, degrading or denying service.
  2. How severe is CVE-2026-107287? CVE-2026-107287 has a CVSS score of 6.5 (Medium). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which packages are affected by CVE-2026-107287?
    • pydantic-ai (pip) (versions >= 1.77.0, < 1.107.7)
    • pydantic-ai-slim (pip) (versions >= 1.77.0, < 1.107.7)
  4. Is there a fix for CVE-2026-107287? Yes. CVE-2026-107287 is fixed in 1.107.7, 2.52.0. Upgrade to this version or later.
  5. Is CVE-2026-107287 exploitable, and should I be worried? Whether CVE-2026-107287 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-107287 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-107287?
    • Upgrade pydantic-ai to 1.107.7 or later
    • Upgrade pydantic-ai to 2.52.0 or later
    • Upgrade pydantic-ai-slim to 1.107.7 or later
    • Upgrade pydantic-ai-slim to 2.52.0 or later

Other vulnerabilities in pydantic-ai

Stop the waste.
Protect your environment with Kodem.