CVE-2026-107295

CVE-2026-107295 is a high-severity cross-site request forgery (CSRF) vulnerability in pydantic-ai (pip), affecting versions >= 1.34.0, < 1.107.4. It is fixed in 1.107.4, 2.28.0.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Pydantic AI Web chat UI (Agent.to_web(), clai web): a website visited by the developer can trigger agent runs and server-side tool execution on the local chat endpoint

The Pydantic AI development web chat UI (Agent.to_web(), clai web) did not check the content type of requests to its chat endpoint. This allowed a website visited by a developer to submit a request to a chat UI running on that developer's machine, causing the served agent to run and to execute its tools with the privileges and credentials of the local process.

Binding the web UI to localhost, the default, does not prevent this, because a page open in the developer's browser can reach the loopback address.

Mitigation

Upgrade to a patched version. The chat endpoint now requires Content-Type: application/json and rejects other requests before the request body is parsed and before the agent runs. The bundled chat UI already sends this header; scripts and other non-browser clients that call the endpoint directly may need to be updated to send it.

If you cannot upgrade, don't run the web UI while browsing untrusted sites, stop it when you aren't using it, and don't serve an agent with side-effecting tools through it.

Credits

  • Thai Son Dinh from VinSOC Labs (R&D)

Impact

Applications and developers serving an agent through Agent.to_web() or clai web. The consequences depend on the tools the served agent exposes, and can include data disclosure as well as unwanted tool side effects. Tools marked requires_approval=True were not protected either, because the endpoint trusts approval decisions relayed by the client.

A victim's authenticated browser session is used to submit forged requests to an application that cannot distinguish them from legitimate ones. Typical impact: state-changing actions performed as the victim without their consent.

CVE-2026-107295 has a CVSS score of 7.6 (High). The vector is network-reachable, no privileges required, and user interaction required. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (1.107.4, 2.28.0); upgrading removes the vulnerable code path.

Affected versions

pydantic-ai (>= 1.34.0, < 1.107.4) pydantic-ai (>= 2.0.0b1, < 2.28.0) pydantic-ai-slim (>= 1.34.0, < 1.107.4) pydantic-ai-slim (>= 2.0.0b1, < 2.28.0)

Security releases

pydantic-ai → 1.107.4 (pip) pydantic-ai → 2.28.0 (pip) pydantic-ai-slim → 1.107.4 (pip) pydantic-ai-slim → 2.28.0 (pip)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade the following packages to resolve this vulnerability:

pydantic-ai to 1.107.4 or later; pydantic-ai to 2.28.0 or later; pydantic-ai-slim to 1.107.4 or later; pydantic-ai-slim to 2.28.0 or later

Kodem Kai can prioritize this vulnerability in your dependency tree and generate a fix recommendation.

Frequently Asked Questions

  1. What is CVE-2026-107295? CVE-2026-107295 is a high-severity cross-site request forgery (CSRF) vulnerability in pydantic-ai (pip), affecting versions >= 1.34.0, < 1.107.4. It is fixed in 1.107.4, 2.28.0. A victim's authenticated browser session is used to submit forged requests to an application that cannot distinguish them from legitimate ones.
  2. How severe is CVE-2026-107295? CVE-2026-107295 has a CVSS score of 7.6 (High). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which packages are affected by CVE-2026-107295?
    • pydantic-ai (pip) (versions >= 1.34.0, < 1.107.4)
    • pydantic-ai-slim (pip) (versions >= 1.34.0, < 1.107.4)
  4. Is there a fix for CVE-2026-107295? Yes. CVE-2026-107295 is fixed in 1.107.4, 2.28.0. Upgrade to this version or later.
  5. Is CVE-2026-107295 exploitable, and should I be worried? Whether CVE-2026-107295 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-107295 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-107295?
    • Upgrade pydantic-ai to 1.107.4 or later
    • Upgrade pydantic-ai to 2.28.0 or later
    • Upgrade pydantic-ai-slim to 1.107.4 or later
    • Upgrade pydantic-ai-slim to 2.28.0 or later

Other vulnerabilities in pydantic-ai

Stop the waste.
Protect your environment with Kodem.