CVE-2026-109924

CVE-2026-109924 is a medium-severity allocation of resources without limits or throttling vulnerability in undici (npm), affecting versions >= 6.5.0, < 6.29.1. It is fixed in 6.29.1, 7.30.1, 8.12.2.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

undici vulnerable to Denial of Service via unbounded memory in the EventSource parser

Workarounds

None.

Impact

undici's EventSource client can be driven to exhaust process memory by a malicious or compromised Server-Sent Events peer. By sending millions of tiny completed data: fields with no blank event separator, or a single unfinished line split across many chunks, the parser retains a growing amount of per-field and per-chunk state. The byte-based maxEventSize and maxResponseSize limits do not bound that retained state, and maxResponseSize is enforced on the compressed body before decompression, so a small compressed response can expand into enough retained memory to terminate the process. The application only needs to maintain an EventSource connection to an untrusted peer, which controls only the response. Availability is the only impact.

The application allocates resources such as memory, threads, or file descriptors based on untrusted input without enforcing a cap. Typical impact: resource exhaustion leading to denial of service.

CVE-2026-109924 has a CVSS score of 5.9 (Medium). The vector is network-reachable, no privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (6.29.1, 7.30.1, 8.12.2); upgrading removes the vulnerable code path.

Affected versions

undici (>= 6.5.0, < 6.29.1) undici (>= 7.0.0, < 7.30.1) undici (>= 8.0.0, < 8.12.2)

Security releases

undici → 6.29.1 (npm) undici → 7.30.1 (npm) undici → 8.12.2 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade to 6.29.1, 7.30.1, or 8.12.2, which bound the retained EventSource parser state (the number of data fields and buffered chunks, the unfinished-line length, and per-field byte totals) independently of the byte limits.

Frequently Asked Questions

  1. What is CVE-2026-109924? CVE-2026-109924 is a medium-severity allocation of resources without limits or throttling vulnerability in undici (npm), affecting versions >= 6.5.0, < 6.29.1. It is fixed in 6.29.1, 7.30.1, 8.12.2. The application allocates resources such as memory, threads, or file descriptors based on untrusted input without enforcing a cap.
  2. How severe is CVE-2026-109924? CVE-2026-109924 has a CVSS score of 5.9 (Medium). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of undici are affected by CVE-2026-109924? undici (npm) versions >= 6.5.0, < 6.29.1 is affected.
  4. Is there a fix for CVE-2026-109924? Yes. CVE-2026-109924 is fixed in 6.29.1, 7.30.1, 8.12.2. Upgrade to this version or later.
  5. Is CVE-2026-109924 exploitable, and should I be worried? Whether CVE-2026-109924 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-109924 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-109924?
    • Upgrade undici to 6.29.1 or later
    • Upgrade undici to 7.30.1 or later
    • Upgrade undici to 8.12.2 or later

Other vulnerabilities in undici

Stop the waste.
Protect your environment with Kodem.