CVE-2026-111771

CVE-2026-111771 is a medium-severity incorrect authorization vulnerability in @modelcontextprotocol/sdk (npm), affecting versions >= 1.6.0, < 1.32.0. It is fixed in 1.32.0, 2.3.0, 2.0.2, 2.3.1.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

MCP TypeScript SDK: Server bearer authentication accepted tokens issued for another service

In affected versions, the SDK's server-side bearer authentication had no way to check that a token was issued for your server (its audience). Where one authorization server issues tokens for several services, a valid token for another service was also accepted by your MCP server.

Am I affected?

Yes, if your HTTP server uses requireBearerAuth() or verifyBearerToken(), its authorization server also issues tokens for other services, and your verifyAccessToken() does not check the token's audience (aud) itself.

Affected versions:

  • @modelcontextprotocol/sdk 1.6.0 through 1.31.0
  • @modelcontextprotocol/server 2.0.0 through 2.2.0
  • @modelcontextprotocol/express 2.0.0 through 2.0.1
  • @modelcontextprotocol/server-legacy 2.0.0 through 2.3.0

Impact

The application does not correctly enforce access controls, allowing a principal to access resources or operations beyond their granted permissions. Typical impact: unauthorized data access or execution of privileged operations.

CVE-2026-111771 has a CVSS score of 6.8 (Medium). The vector is network-reachable, low privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (1.32.0, 2.3.0, 2.0.2, 2.3.1); upgrading removes the vulnerable code path.

Affected versions

@modelcontextprotocol/sdk (>= 1.6.0, < 1.32.0) @modelcontextprotocol/server (>= 2.0.0, < 2.3.0) @modelcontextprotocol/express (>= 2.0.0, < 2.0.2) @modelcontextprotocol/server-legacy (>= 2.0.0, < 2.3.1)

Security releases

@modelcontextprotocol/sdk → 1.32.0 (npm) @modelcontextprotocol/server → 2.3.0 (npm) @modelcontextprotocol/express → 2.0.2 (npm) @modelcontextprotocol/server-legacy → 2.3.1 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade to:

  • 1.x: @modelcontextprotocol/sdk 1.32.0 or later
  • 2.x: @modelcontextprotocol/server 2.3.0 or later, together with @modelcontextprotocol/express 2.0.2 or later if you use it
  • @modelcontextprotocol/server-legacy 2.3.1 or later

Upgrading alone changes nothing. The patched versions add an expectedResource setting that is off by default. To turn the check on, make both of these changes together:

  1. Pass the audience your authorization server puts in tokens for your server: requireBearerAuth({ verifier, expectedResource: new URL('https://mcp.example.com/mcp') }).
  2. Return the token's audience from verifyAccessToken() as AuthInfo.resource, also a URL.

A token for another service then gets 401. With only the first change, every request gets 401.

If you cannot upgrade yet, reject any token whose aud does not include your server inside verifyAccessToken(). That closes the issue on every version.

Frequently Asked Questions

  1. What is CVE-2026-111771? CVE-2026-111771 is a medium-severity incorrect authorization vulnerability in @modelcontextprotocol/sdk (npm), affecting versions >= 1.6.0, < 1.32.0. It is fixed in 1.32.0, 2.3.0, 2.0.2, 2.3.1. The application does not correctly enforce access controls, allowing a principal to access resources or operations beyond their granted permissions.
  2. How severe is CVE-2026-111771? CVE-2026-111771 has a CVSS score of 6.8 (Medium). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which packages are affected by CVE-2026-111771?
    • @modelcontextprotocol/sdk (npm) (versions >= 1.6.0, < 1.32.0)
    • @modelcontextprotocol/server (npm) (versions >= 2.0.0, < 2.3.0)
    • @modelcontextprotocol/express (npm) (versions >= 2.0.0, < 2.0.2)
    • @modelcontextprotocol/server-legacy (npm) (versions >= 2.0.0, < 2.3.1)
  4. Is there a fix for CVE-2026-111771? Yes. CVE-2026-111771 is fixed in 1.32.0, 2.3.0, 2.0.2, 2.3.1. Upgrade to this version or later.
  5. Is CVE-2026-111771 exploitable, and should I be worried? Whether CVE-2026-111771 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-111771 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-111771?
    • Upgrade @modelcontextprotocol/sdk to 1.32.0 or later
    • Upgrade @modelcontextprotocol/server to 2.3.0 or later
    • Upgrade @modelcontextprotocol/express to 2.0.2 or later
    • Upgrade @modelcontextprotocol/server-legacy to 2.3.1 or later

Other vulnerabilities in @modelcontextprotocol/sdk

Stop the waste.
Protect your environment with Kodem.