Summary
MCP TypeScript SDK: HTTP server transports and handlers did not limit request body size or JSON-RPC batch length
In affected versions, MCP servers reachable over HTTP put no limit on the size of a POST body or on the number of messages in a JSON-RPC batch. Large requests could exhaust the server's memory, and one long batch could block it from serving anyone else. No credentials were needed, unless your application authenticates requests before they reach the SDK.
Am I affected?
Yes, if clients you do not fully trust can reach your server over Streamable HTTP. A body parser such as express.json() does not protect you, because it does not limit batch length. Servers that only use stdio are not affected.
Affected versions:
@modelcontextprotocol/sdk1.10.0 through 1.30.0@modelcontextprotocol/server2.0.0@modelcontextprotocol/node2.0.0@modelcontextprotocol/hono2.0.0
Impact
The application allocates resources such as memory, threads, or file descriptors based on untrusted input without enforcing a cap. Typical impact: resource exhaustion leading to denial of service.
GHSA-F897-62HF-6GXQ has a CVSS score of 7.5 (High). The vector is network-reachable, no privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (1.30.1, 2.1.0, 2.0.1); upgrading removes the vulnerable code path.
Affected versions
Security releases
Kodem intelligence
Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.
Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.
Already deployed Kodem?
See it in your environmentNew to Kodem? Get a demo →Remediation advice
Upgrade to:
- 1.x:
@modelcontextprotocol/sdk1.30.1 or later - 2.x:
@modelcontextprotocol/server2.1.0,@modelcontextprotocol/node2.1.0 and@modelcontextprotocol/hono2.0.1 or later. Upgrade every one you have installed.
Bodies over 4 MiB now get 413, and batches over 100 messages get 400. If your clients send larger bodies, raise the new maxRequestBodySize option.
If you cannot upgrade yet, cap request body size in a reverse proxy.
Frequently Asked Questions
- What is GHSA-F897-62HF-6GXQ? GHSA-F897-62HF-6GXQ is a high-severity allocation of resources without limits or throttling vulnerability in @modelcontextprotocol/sdk (npm), affecting versions >= 1.10.0, < 1.30.1. It is fixed in 1.30.1, 2.1.0, 2.0.1. The application allocates resources such as memory, threads, or file descriptors based on untrusted input without enforcing a cap.
- How severe is GHSA-F897-62HF-6GXQ? GHSA-F897-62HF-6GXQ has a CVSS score of 7.5 (High). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
- Which packages are affected by GHSA-F897-62HF-6GXQ?
@modelcontextprotocol/sdk(npm) (versions >= 1.10.0, < 1.30.1)@modelcontextprotocol/server(npm) (versions >= 2.0.0, < 2.1.0)@modelcontextprotocol/node(npm) (versions >= 2.0.0, < 2.1.0)@modelcontextprotocol/hono(npm) (versions >= 2.0.0, < 2.0.1)
- Is there a fix for GHSA-F897-62HF-6GXQ? Yes. GHSA-F897-62HF-6GXQ is fixed in 1.30.1, 2.1.0, 2.0.1. Upgrade to this version or later.
- Is GHSA-F897-62HF-6GXQ exploitable, and should I be worried? Whether GHSA-F897-62HF-6GXQ is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
- What actually determines whether GHSA-F897-62HF-6GXQ is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
- How do I fix GHSA-F897-62HF-6GXQ?
- Upgrade
@modelcontextprotocol/sdkto 1.30.1 or later - Upgrade
@modelcontextprotocol/serverto 2.1.0 or later - Upgrade
@modelcontextprotocol/nodeto 2.1.0 or later - Upgrade
@modelcontextprotocol/honoto 2.0.1 or later
- Upgrade