CVE-2026-112942

CVE-2026-112942 is a high-severity command injection vulnerability in launch-editor (npm), affecting versions <= 2.14.1. It is fixed in 2.14.2, 8.3.3, 8.2.4, 8.1.6, 7.3.7, 6.4.4, 1.1.0.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

launch-editor: fs.existsSync() existence check can be bypassed on Windows

launch-editor checked fs.existsSync(fileName) before passing a supplied path to an editor command. On Windows, an attacker can bypass this check with a crafted path ending in \\..:line:column. This removes the requirement that the attacker be able to place a file with a malicious filename.

Combined with the % escaping issue described in GHSA-698v-4r3x-3vcv, this bypass can lead to OS command injection when an attacker controls the file argument.

Details

The earlier advisory assumed that fs.existsSync() required an attacker-controlled filename to exist. This advisory covers a bypass of that requirement.

A crafted value ending in \\..:1:1 is interpreted differently by launch-editor-middleware, launch-editor, and Windows:

  1. launch-editor-middleware calls path.resolve() while the final path component is ..:1:1, so it is not treated as a parent-directory component.
  2. launch-editor treats :1:1 as a line-and-column suffix and removes it, leaving a path ending in \\...
  3. On Windows, fs.existsSync() accepts the resulting path as the existing parent directory even though the attacker-controlled preceding component does not exist.
  4. Because the existence check passes, the crafted filename reaches the Windows shell command.

Impact

Only apps that runs on Windows is affected.

Untrusted input is inserted into a command that is later executed by the application, allowing the attacker to alter the intent of that command. Typical impact: arbitrary command execution in the application's environment.

Affected versions

launch-editor (<= 2.14.1) vite (>= 8.3.0, <= 8.3.2) vite (>= 8.2.0, <= 8.2.3) vite (>= 8.0.0, <= 8.1.5) vite (>= 7.0.0, <= 7.3.6) vite (<= 6.4.3) vite-plus (<= 1.0.0)

Security releases

launch-editor → 2.14.2 (npm) vite → 8.3.3 (npm) vite → 8.2.4 (npm) vite → 8.1.6 (npm) vite → 7.3.7 (npm) vite → 6.4.4 (npm) vite-plus → 1.1.0 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade the following packages to resolve this vulnerability:

launch-editor to 2.14.2 or later; vite to 8.3.3 or later; vite to 8.2.4 or later; vite to 8.1.6 or later; vite to 7.3.7 or later; vite to 6.4.4 or later; vite-plus to 1.1.0 or later

Kodem Kai can prioritize this vulnerability in your dependency tree and generate a fix recommendation.

Frequently Asked Questions

  1. What is CVE-2026-112942? CVE-2026-112942 is a high-severity command injection vulnerability in launch-editor (npm), affecting versions <= 2.14.1. It is fixed in 2.14.2, 8.3.3, 8.2.4, 8.1.6, 7.3.7, 6.4.4, 1.1.0. Untrusted input is inserted into a command that is later executed by the application, allowing the attacker to alter the intent of that command.
  2. Which packages are affected by CVE-2026-112942?
    • launch-editor (npm) (versions <= 2.14.1)
    • vite (npm) (versions >= 8.3.0, <= 8.3.2)
    • vite-plus (npm) (versions <= 1.0.0)
  3. Is there a fix for CVE-2026-112942? Yes. CVE-2026-112942 is fixed in 2.14.2, 8.3.3, 8.2.4, 8.1.6, 7.3.7, 6.4.4, 1.1.0. Upgrade to this version or later.
  4. Is CVE-2026-112942 exploitable, and should I be worried? Whether CVE-2026-112942 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  5. What actually determines whether CVE-2026-112942 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  6. How do I fix CVE-2026-112942?
    • Upgrade launch-editor to 2.14.2 or later
    • Upgrade vite to 8.3.3 or later
    • Upgrade vite to 8.2.4 or later
    • Upgrade vite to 8.1.6 or later
    • Upgrade vite to 7.3.7 or later
    • Upgrade vite to 6.4.4 or later
    • Upgrade vite-plus to 1.1.0 or later

Other vulnerabilities in launch-editor

Stop the waste.
Protect your environment with Kodem.