CVE-2026-112943

CVE-2026-112943 is a medium-severity OS command injection vulnerability in launch-editor (npm), affecting versions <= 2.14.1. It is fixed in 2.14.2, 8.3.3, 8.2.4, 8.1.6, 7.3.7, 6.4.4, 1.1.0.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

launch-editor: escapeCmdArgs() omits % escaping on Windows

launch-editor did not escape % on Windows when passing an argument to cmd. When an environment variable contained a malicious value, it was possible that that content to be executed.

Details

Unlike .sh files, .bat / .cmd files on Windows cannot be called directly using child_process.spawn and requires passing them as an argument of cmd.exe. To do so, launch-editor escapes the arguments passed to cmd.exe. But launch-editor did not escape % which is used for environment variables.

Because launch-editor checks if the argument matches an existing filename, the attack requires the attacker to be able to place a file.

  • If the attacker can inject an environment variable as well, they can include the subcommand in the env variable (e.g. set &calc.exe to %ENV%) and call launchEditor with something%ENV%.
  • If the attacker can place a NTFS alternate data stream to the file (e.g. a NTFS alternate data stream named ~-38%calc.exe), they can call launchEditor with something %CMDCMDLINE:~-38%calc.exe.
  • If the attacker can create a filename containing the %CD% and the subcommand (e.g. &calc.exe ), they can call launchEditor with ./%CD%

Impact

Only apps that match all of the following conditions are affected:

  • The user uses Windows
  • An attacker can place a file with the malicious filename containing & or %
  • Either of
    • An attacker can inject an environment variable with a malicious value
    • An attacker can add a NTFS alternate data stream to the file placed

Untrusted input reaches a shell command, allowing arbitrary commands to run on the host. Typical impact: code execution in the application's environment.

Affected versions

launch-editor (<= 2.14.1) vite (>= 8.3.0, <= 8.3.2) vite (>= 8.2.0, <= 8.2.3) vite (>= 8.0.0, <= 8.1.5) vite (>= 7.0.0, <= 7.3.6) vite (<= 6.4.3) vite-plus (<= 1.0.0)

Security releases

launch-editor → 2.14.2 (npm) vite → 8.3.3 (npm) vite → 8.2.4 (npm) vite → 8.1.6 (npm) vite → 7.3.7 (npm) vite → 6.4.4 (npm) vite-plus → 1.1.0 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade the following packages to resolve this vulnerability:

launch-editor to 2.14.2 or later; vite to 8.3.3 or later; vite to 8.2.4 or later; vite to 8.1.6 or later; vite to 7.3.7 or later; vite to 6.4.4 or later; vite-plus to 1.1.0 or later

Kodem Kai can prioritize this vulnerability in your dependency tree and generate a fix recommendation.

Frequently Asked Questions

  1. What is CVE-2026-112943? CVE-2026-112943 is a medium-severity OS command injection vulnerability in launch-editor (npm), affecting versions <= 2.14.1. It is fixed in 2.14.2, 8.3.3, 8.2.4, 8.1.6, 7.3.7, 6.4.4, 1.1.0. Untrusted input reaches a shell command, allowing arbitrary commands to run on the host.
  2. Which packages are affected by CVE-2026-112943?
    • launch-editor (npm) (versions <= 2.14.1)
    • vite (npm) (versions >= 8.3.0, <= 8.3.2)
    • vite-plus (npm) (versions <= 1.0.0)
  3. Is there a fix for CVE-2026-112943? Yes. CVE-2026-112943 is fixed in 2.14.2, 8.3.3, 8.2.4, 8.1.6, 7.3.7, 6.4.4, 1.1.0. Upgrade to this version or later.
  4. Is CVE-2026-112943 exploitable, and should I be worried? Whether CVE-2026-112943 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  5. What actually determines whether CVE-2026-112943 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  6. How do I fix CVE-2026-112943?
    • Upgrade launch-editor to 2.14.2 or later
    • Upgrade vite to 8.3.3 or later
    • Upgrade vite to 8.2.4 or later
    • Upgrade vite to 8.1.6 or later
    • Upgrade vite to 7.3.7 or later
    • Upgrade vite to 6.4.4 or later
    • Upgrade vite-plus to 1.1.0 or later

Other vulnerabilities in launch-editor

Stop the waste.
Protect your environment with Kodem.