CVE-2026-114508

CVE-2026-114508 is a medium-severity security vulnerability in laravel/framework (composer), affecting versions >= 12.45.0, < 12.68.0. It is fixed in 12.68.0, 13.27.0.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Laravel relationship inclusion can trigger unauthorized data destruction

A vulnerability in how relationship inclusion is processed on certain read endpoints. Under specific conditions, a request to a read-only endpoint can be crafted to trigger a destructive database operation on a related table, rather than simply retrieving data.

Impact

A user with only read access could cause irreversible data loss (e.g., a related table being emptied), without needing any write permissions. This could result in denial of service and loss of data integrity for affected applications.

CVE-2026-114508 has a CVSS score of 6.5 (Medium). The vector is network-reachable, no privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (12.68.0, 13.27.0); upgrading removes the vulnerable code path.

Affected versions

laravel/framework (>= 12.45.0, < 12.68.0) laravel/framework (>= 13.0.0, < 13.27.0)

Security releases

laravel/framework → 12.68.0 (composer) laravel/framework → 13.27.0 (composer)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade the following packages to resolve this vulnerability:

laravel/framework to 12.68.0 or later; laravel/framework to 13.27.0 or later

Kodem Kai can prioritize this vulnerability in your dependency tree and generate a fix recommendation.

Frequently Asked Questions

  1. What is CVE-2026-114508? CVE-2026-114508 is a medium-severity security vulnerability in laravel/framework (composer), affecting versions >= 12.45.0, < 12.68.0. It is fixed in 12.68.0, 13.27.0.
  2. How severe is CVE-2026-114508? CVE-2026-114508 has a CVSS score of 6.5 (Medium). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of laravel/framework are affected by CVE-2026-114508? laravel/framework (composer) versions >= 12.45.0, < 12.68.0 is affected.
  4. Is there a fix for CVE-2026-114508? Yes. CVE-2026-114508 is fixed in 12.68.0, 13.27.0. Upgrade to this version or later.
  5. Is CVE-2026-114508 exploitable, and should I be worried? Whether CVE-2026-114508 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-114508 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-114508?
    • Upgrade laravel/framework to 12.68.0 or later
    • Upgrade laravel/framework to 13.27.0 or later

Other vulnerabilities in laravel/framework

Stop the waste.
Protect your environment with Kodem.