CVE-2026-114509

CVE-2026-114509 is a critical-severity improper authentication vulnerability in laravel/framework (composer), affecting versions >= 13.0.0, < 13.29.0. It is fixed in 13.29.0, 12.68.0.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Laravel TokenGuard authentication bypass through non-string API credentials

Laravel's built-in TokenGuard, when configured with a standard token-based API guard, may be bypassed to authenticate as an arbitrary existing user without knowledge of their valid API token.

Under certain database configurations (MySQL/MariaDB) an attacker can submit a specially crafted, non-string credential value that is mishandled during the authentication lookup, causing the underlying query to match an unintended user record rather than failing authentication as expected.

Impact

An unauthenticated attacker may authenticate as another user without possessing that user's API token, leading to authentication bypass and account takeover on any route protected by the affected guard.

The application does not adequately verify the identity of a user, device, or process before granting access. Typical impact: unauthorized access to functions or data reserved for authenticated parties.

Affected versions

laravel/framework (>= 13.0.0, < 13.29.0) laravel/framework (< 12.68.0)

Security releases

laravel/framework → 13.29.0 (composer) laravel/framework → 12.68.0 (composer)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade the following packages to resolve this vulnerability:

laravel/framework to 13.29.0 or later; laravel/framework to 12.68.0 or later

Kodem Kai can prioritize this vulnerability in your dependency tree and generate a fix recommendation.

Frequently Asked Questions

  1. What is CVE-2026-114509? CVE-2026-114509 is a critical-severity improper authentication vulnerability in laravel/framework (composer), affecting versions >= 13.0.0, < 13.29.0. It is fixed in 13.29.0, 12.68.0. The application does not adequately verify the identity of a user, device, or process before granting access.
  2. Which versions of laravel/framework are affected by CVE-2026-114509? laravel/framework (composer) versions >= 13.0.0, < 13.29.0 is affected.
  3. Is there a fix for CVE-2026-114509? Yes. CVE-2026-114509 is fixed in 13.29.0, 12.68.0. Upgrade to this version or later.
  4. Is CVE-2026-114509 exploitable, and should I be worried? Whether CVE-2026-114509 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  5. What actually determines whether CVE-2026-114509 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  6. How do I fix CVE-2026-114509?
    • Upgrade laravel/framework to 13.29.0 or later
    • Upgrade laravel/framework to 12.68.0 or later

Other vulnerabilities in laravel/framework

Stop the waste.
Protect your environment with Kodem.