CVE-2026-116687

CVE-2026-116687 is a low-severity cross-site scripting (XSS) vulnerability in ckeditor5 (npm), affecting versions >= 29.0.0, < 47.7.4. It is fixed in 47.7.4, 48.5.1.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

CKEditor: Cross-site scripting (XSS) in the engine package

For more information

Email us at [email protected] if you have any questions or comments about this advisory.

Impact

A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability could be triggered by inserting specially crafted markup under a specific General HTML Support configuration that allows inserting objects, leading to unauthorized JavaScript code execution in a browser context isolated from the origin of the application embedding the editor.

This vulnerability affects only installations where General HTML Support is enabled and configured to allow the affected HTML content.

Untrusted input is rendered as active markup in a victim's browser, which can run script in their session. Typical impact: session or credential theft, and actions taken as the user.

CVE-2026-116687 has a CVSS score of 3.1 (Low). The vector is network-reachable, low privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (47.7.4, 48.5.1); upgrading removes the vulnerable code path.

Affected versions

ckeditor5 (>= 29.0.0, < 47.7.4) @ckeditor/ckeditor5-engine (>= 29.0.0, < 47.7.4) ckeditor5 (>= 48.0.0, < 48.5.1) @ckeditor/ckeditor5-engine (>= 48.0.0, < 48.5.1)

Security releases

ckeditor5 → 47.7.4 (npm) @ckeditor/ckeditor5-engine → 47.7.4 (npm) ckeditor5 → 48.5.1 (npm) @ckeditor/ckeditor5-engine → 48.5.1 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

The problem has been recognized and patched. The fix will be available in version 48.5.1 (and above) and 47.7.4 (LTS).

Frequently Asked Questions

  1. What is CVE-2026-116687? CVE-2026-116687 is a low-severity cross-site scripting (XSS) vulnerability in ckeditor5 (npm), affecting versions >= 29.0.0, < 47.7.4. It is fixed in 47.7.4, 48.5.1. Untrusted input is rendered as active markup in a victim's browser, which can run script in their session.
  2. How severe is CVE-2026-116687? CVE-2026-116687 has a CVSS score of 3.1 (Low). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which packages are affected by CVE-2026-116687?
    • ckeditor5 (npm) (versions >= 29.0.0, < 47.7.4)
    • @ckeditor/ckeditor5-engine (npm) (versions >= 29.0.0, < 47.7.4)
  4. Is there a fix for CVE-2026-116687? Yes. CVE-2026-116687 is fixed in 47.7.4, 48.5.1. Upgrade to this version or later.
  5. Is CVE-2026-116687 exploitable, and should I be worried? Whether CVE-2026-116687 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-116687 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-116687?
    • Upgrade ckeditor5 to 47.7.4 or later
    • Upgrade @ckeditor/ckeditor5-engine to 47.7.4 or later
    • Upgrade ckeditor5 to 48.5.1 or later
    • Upgrade @ckeditor/ckeditor5-engine to 48.5.1 or later

Other vulnerabilities in ckeditor5

Stop the waste.
Protect your environment with Kodem.