Summary
CKEditor: Cross-site scripting (XSS) in the engine package
For more information
Email us at [email protected] if you have any questions or comments about this advisory.
Impact
A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability is caused by a prototype pollution issue in the es-toolkit library used in the CKEditor 5 codebase. This vulnerability could lead to unauthorized JavaScript code execution when the editor processes incoming style attribute values.
The underlying issue has been patched by the library maintainers, and the fix has been incorporated into CKEditor 5.
Untrusted input is rendered as active markup in a victim's browser, which can run script in their session. Typical impact: session or credential theft, and actions taken as the user.
CVE-2026-116688 has a CVSS score of 8.1 (High). The vector is network-reachable, low privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (47.7.4, 48.5.1); upgrading removes the vulnerable code path.
Affected versions
Security releases
Kodem intelligence
Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.
Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.
Already deployed Kodem?
See it in your environmentNew to Kodem? Get a demo →Remediation advice
The problem has been recognized and patched. The fix will be available in version 48.5.1 (and above) and 47.7.4 (LTS).
Frequently Asked Questions
- What is CVE-2026-116688? CVE-2026-116688 is a high-severity cross-site scripting (XSS) vulnerability in ckeditor5 (npm), affecting versions >= 45.0.0, < 47.7.4. It is fixed in 47.7.4, 48.5.1. Untrusted input is rendered as active markup in a victim's browser, which can run script in their session.
- How severe is CVE-2026-116688? CVE-2026-116688 has a CVSS score of 8.1 (High). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
- Which packages are affected by CVE-2026-116688?
ckeditor5(npm) (versions >= 45.0.0, < 47.7.4)@ckeditor/ckeditor5-engine(npm) (versions >= 45.0.0, < 47.7.4)
- Is there a fix for CVE-2026-116688? Yes. CVE-2026-116688 is fixed in 47.7.4, 48.5.1. Upgrade to this version or later.
- Is CVE-2026-116688 exploitable, and should I be worried? Whether CVE-2026-116688 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
- What actually determines whether CVE-2026-116688 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
- How do I fix CVE-2026-116688?
- Upgrade
ckeditor5to 47.7.4 or later - Upgrade
@ckeditor/ckeditor5-engineto 47.7.4 or later - Upgrade
ckeditor5to 48.5.1 or later - Upgrade
@ckeditor/ckeditor5-engineto 48.5.1 or later
- Upgrade