CVE-2026-116797

CVE-2026-116797 is a high-severity cross-site scripting (XSS) vulnerability in @highcharts/grid-pro (npm), affecting versions >= 2.0.0, <= 3.1.0. It is fixed in 3.2.0, 4.0.0.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Highcharts Grid Pro: cell-renderer attributes map written with raw setAttribute

Workarounds

If your column configuration comes from a source you do not fully control, paste this snippet right after importing the Grid module:

const ALLOWED_RENDERER_ATTRIBUTES = [
    'autofocus', 'checked', 'max', 'maxlength', 'min', 'minlength',
    'multiple', 'pattern', 'placeholder', 'size', 'step'
];

const scrubColumn = (column) => {
    const cells = column?.cells;

    for (const renderer of [cells?.renderer, cells?.editMode?.renderer]) {
        const attributes = renderer?.attributes;

        if (attributes) {
            for (const key of Object.keys(attributes)) {
                if (!ALLOWED_RENDERER_ATTRIBUTES.includes(key.toLowerCase())) {
                    delete attributes[key];
                }
            }
        }
    }

    return column;
};

const scrubOptions = (options) => {
    scrubColumn(options?.columnDefaults);
    (options?.columns || []).forEach(scrubColumn);
    return options;
};

const proto = Grid.Grid.prototype;

const loadUserOptions = proto.loadUserOptions;
proto.loadUserOptions = function (options, ...rest) {
    scrubOptions(Grid.defaultOptions);
    return loadUserOptions.call(this, scrubOptions(options), ...rest);
};

const updateColumn = proto.updateColumn;
proto.updateColumn = function (columnId, options, ...rest) {
    return updateColumn.call(this, columnId, scrubColumn(options), ...rest);
};

Obtaining the patched version

The patched releases are available from all the usual distribution channels. With npm, upgrade the affected package to the patched version listed above, for example npm install @highcharts/[email protected]. If you load Highcharts Grid from a CDN, use a versioned URL, for example https://cdn.jsdelivr.net/npm/@highcharts/[email protected]/grid-lite.js. For more on each installation method, see the installation guide.

Impact

The input-type cell renderers copy every entry of the renderer's attributes option onto the input or select element they create, without checking the attribute names. An attacker who controls the Grid configuration can supply entries under a column's cells.renderer.attributes or cells.editMode.renderer.attributes whose names are event handlers, and those handlers execute in the origin of the page hosting the Grid. A view renderer places the handler on the input rendered in every row of the column as soon as the Grid renders; an edit-mode renderer places it on the input created when a cell enters edit mode, and that input is focused immediately, so a focus handler runs as soon as the user starts editing. Exploitation requires that untrusted data reach the Grid configuration and that a user hover over or focus one of the rendered inputs, or begin editing a cell. The Pro DataGrid that shipped inside the Dashboards package is included.

Untrusted input is rendered as active markup in a victim's browser, which can run script in their session. Typical impact: session or credential theft, and actions taken as the user.

Affected versions

@highcharts/grid-pro (>= 2.0.0, <= 3.1.0) @highcharts/dashboards (= 3.6.0)

Security releases

@highcharts/grid-pro → 3.2.0 (npm) @highcharts/dashboards → 4.0.0 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade the following packages to resolve this vulnerability:

@highcharts/grid-pro to 3.2.0 or later; @highcharts/dashboards to 4.0.0 or later

Kodem Kai can prioritize this vulnerability in your dependency tree and generate a fix recommendation.

Frequently Asked Questions

  1. What is CVE-2026-116797? CVE-2026-116797 is a high-severity cross-site scripting (XSS) vulnerability in @highcharts/grid-pro (npm), affecting versions >= 2.0.0, <= 3.1.0. It is fixed in 3.2.0, 4.0.0. Untrusted input is rendered as active markup in a victim's browser, which can run script in their session.
  2. Which packages are affected by CVE-2026-116797?
    • @highcharts/grid-pro (npm) (versions >= 2.0.0, <= 3.1.0)
    • @highcharts/dashboards (npm) (versions = 3.6.0)
  3. Is there a fix for CVE-2026-116797? Yes. CVE-2026-116797 is fixed in 3.2.0, 4.0.0. Upgrade to this version or later.
  4. Is CVE-2026-116797 exploitable, and should I be worried? Whether CVE-2026-116797 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  5. What actually determines whether CVE-2026-116797 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  6. How do I fix CVE-2026-116797?
    • Upgrade @highcharts/grid-pro to 3.2.0 or later
    • Upgrade @highcharts/dashboards to 4.0.0 or later

Other vulnerabilities in @highcharts/grid-pro

Stop the waste.
Protect your environment with Kodem.