CVE-2026-118255

CVE-2026-118255 is a high-severity cross-site scripting (XSS) vulnerability in @highcharts/dashboards (npm), affecting versions >= 3.2.0, <= 3.6.0. It is fixed in 4.0.0, 3.2.0.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Highcharts Grid: javascript: URL in credits.href runs script on click

Workarounds

Paste in after the Grid Pro module is imported, before a Grid is created.

const { AST } = Grid;

function sanitize(options) {
    const credits = options && options.credits;

    if (credits && typeof credits.href === 'string') {
        const filtered = AST.filterUserAttributes({ href: credits.href });

        if (!filtered.href) {
            delete credits.href;
        }
    }

    return options;
}

// Both Grid.grid() and grid.update() funnel through loadUserOptions, so one
// hook covers both entry points.
const { prototype } = Grid.Grid;
const loadUserOptions = prototype.loadUserOptions;

prototype.loadUserOptions = function (options, ...rest) {
    sanitize(options);
    return loadUserOptions.call(this, options, ...rest);
};

Obtaining the patched version

The patched releases are available from all the usual distribution channels. With npm, upgrade the affected package to the patched version listed above, for example npm install @highcharts/[email protected]. If you load Highcharts Grid from a CDN, use a versioned URL, for example https://cdn.jsdelivr.net/npm/@highcharts/[email protected]/grid-lite.js. For more on each installation method, see the installation guide.

Impact

An attacker who controls the Grid configuration can set credits.href to a javascript: URL. The value is not validated against an allowed-scheme list before it is applied to the credits link, so activating that link runs attacker-supplied script in the origin of the page hosting the Grid. Exploitation requires that untrusted data reach the Grid configuration and that a user activate the credits link. Script running this way has the same access to page data, storage and session state as the hosting application.

Untrusted input is rendered as active markup in a victim's browser, which can run script in their session. Typical impact: session or credential theft, and actions taken as the user.

Affected versions

@highcharts/dashboards (>= 3.2.0, <= 3.6.0) @highcharts/grid-pro (>= 2.0.0, <= 3.1.0)

Security releases

@highcharts/dashboards → 4.0.0 (npm) @highcharts/grid-pro → 3.2.0 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade the following packages to resolve this vulnerability:

@highcharts/dashboards to 4.0.0 or later; @highcharts/grid-pro to 3.2.0 or later

Kodem Kai can prioritize this vulnerability in your dependency tree and generate a fix recommendation.

Frequently Asked Questions

  1. What is CVE-2026-118255? CVE-2026-118255 is a high-severity cross-site scripting (XSS) vulnerability in @highcharts/dashboards (npm), affecting versions >= 3.2.0, <= 3.6.0. It is fixed in 4.0.0, 3.2.0. Untrusted input is rendered as active markup in a victim's browser, which can run script in their session.
  2. Which packages are affected by CVE-2026-118255?
    • @highcharts/dashboards (npm) (versions >= 3.2.0, <= 3.6.0)
    • @highcharts/grid-pro (npm) (versions >= 2.0.0, <= 3.1.0)
  3. Is there a fix for CVE-2026-118255? Yes. CVE-2026-118255 is fixed in 4.0.0, 3.2.0. Upgrade to this version or later.
  4. Is CVE-2026-118255 exploitable, and should I be worried? Whether CVE-2026-118255 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  5. What actually determines whether CVE-2026-118255 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  6. How do I fix CVE-2026-118255?
    • Upgrade @highcharts/dashboards to 4.0.0 or later
    • Upgrade @highcharts/grid-pro to 3.2.0 or later

Other vulnerabilities in @highcharts/dashboards

Stop the waste.
Protect your environment with Kodem.