CVE-2026-118252

CVE-2026-118252 is a high-severity cross-site scripting (XSS) vulnerability in @highcharts/dashboards (npm), affecting versions >= 1.0.0, <= 4.2.2. It is fixed in 4.2.3.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Highcharts Dashboards parses sidebar component labels as HTML

Workarounds

Until you can upgrade, patch EditMode once at application startup. The hook runs before the sidebar is built, so the labels are already harmless by the time they are rendered. Assigning a string to textContent and reading back innerHTML turns any markup into literal text, which is exactly what the fixed version renders.

After importing the module, use this code snipped once, before any board is created.

{
    const EditMode = window.Dashboards?.EditMode;
    const escapeHTML = (text) => text
        .replace(/&/g, '&amp;')
        .replace(/</g, '&lt;')
        .replace(/>/g, '&gt;');
    const patched = new WeakSet();
    const originalInit = EditMode.prototype.init;

    EditMode.prototype.init = function (...args) {
        const labels = this.lang?.sidebar;

        if (labels && !patched.has(this)) {
            patched.add(this);

            for (const key of Object.keys(labels)) {
                if (typeof labels[key] === 'string') {
                    labels[key] = escapeHTML(labels[key]);
                }
            }
        }

        return originalInit.apply(this, args);
    };
}

If your application does not need Edit Mode, leaving it disabled (editMode.enabled: false) removes the exposure as well.

Obtaining the patched version

The patched releases are available from all the usual distribution channels. With npm, upgrade the affected package to the patched version listed above, for example npm install @highcharts/[email protected]. If you load Highcharts Dashboards from a CDN, use a versioned URL, for example https://code.highcharts.com/dashboards/4.2.3/dashboards.js. For more on each installation method, see the installation guide.

Impact

The component language strings shown in the edit mode sidebar are parsed as HTML rather than inserted as text. An attacker who controls those language options can supply markup carrying event handlers, which execute in the origin of the page hosting the dashboard once the sidebar renders the affected labels. Exploitation requires that untrusted data reach the Dashboards language configuration and that a user open the edit mode sidebar.

Untrusted input is rendered as active markup in a victim's browser, which can run script in their session. Typical impact: session or credential theft, and actions taken as the user.

Affected versions

@highcharts/dashboards (>= 1.0.0, <= 4.2.2)

Security releases

@highcharts/dashboards → 4.2.3 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade @highcharts/dashboards to 4.2.3 or later to resolve this vulnerability.

Kodem Kai can prioritize this vulnerability in your dependency tree and generate a fix recommendation.

Frequently Asked Questions

  1. What is CVE-2026-118252? CVE-2026-118252 is a high-severity cross-site scripting (XSS) vulnerability in @highcharts/dashboards (npm), affecting versions >= 1.0.0, <= 4.2.2. It is fixed in 4.2.3. Untrusted input is rendered as active markup in a victim's browser, which can run script in their session.
  2. Which versions of @highcharts/dashboards are affected by CVE-2026-118252? @highcharts/dashboards (npm) versions >= 1.0.0, <= 4.2.2 is affected.
  3. Is there a fix for CVE-2026-118252? Yes. CVE-2026-118252 is fixed in 4.2.3. Upgrade to this version or later.
  4. Is CVE-2026-118252 exploitable, and should I be worried? Whether CVE-2026-118252 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  5. What actually determines whether CVE-2026-118252 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  6. How do I fix CVE-2026-118252? Upgrade @highcharts/dashboards to 4.2.3 or later.

Other vulnerabilities in @highcharts/dashboards

Stop the waste.
Protect your environment with Kodem.