CVE-2026-118243

CVE-2026-118243 is a medium-severity security vulnerability in @highcharts/dashboards (npm), affecting versions >= 1.0.0, <= 4.2.1. It is fixed in 4.2.2.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Highcharts Dashboards: proto data table id writes sync listeners to Object.prototype

Workarounds

Drop-in fix - for any Highcharts Dashboards versions affected (1.0.0-4.2.1).
Add the below IIFE to run after Highcharts Dashboards is loaded.

!function(t){if(t&&t.DataCursor&&t.DataTable){var e=t.DataCursor.prototype,r=t.DataTable.prototype;e.tableIdPollutionPatched||(e.tableIdPollutionPatched=!0,null!==Object.getPrototypeOf((new t.DataCursor).listenerMap)&&['addListener','emitCursor','remitCursor','removeListener'].forEach(function(t){var r=e[t];r&&(e[t]=function(){var t;return t=this,['listenerMap','stateMap'].forEach(function(e){var r,a=t[e];a&&null!==Object.getPrototypeOf(a)&&(r=Object.create(null),Object.keys(a).forEach(function(t){r[t]=a[t]}),t[e]=r)}),r.apply(this,arguments)})}),'__proto__'!==new t.DataTable({id:'__proto__'}).id||Object.getOwnPropertyDescriptor(r,'id')||Object.defineProperty(r,'id',{configurable:!0,enumerable:!0,get:function(){return this.safeTableId},set:function(e){'__proto__'!==e&&'constructor'!==e||(e=t.uniqueKey(),this.autoId=!0),this.safeTableId=e}}))}}(Dashboards);

Live demo & testing

Obtaining the patched version

The patched releases are available from all the usual distribution channels. With npm, upgrade the affected package to the patched version listed above, for example npm install @highcharts/[email protected]. If you load Highcharts Dashboards from a CDN, use a versioned URL, for example https://code.highcharts.com/dashboards/4.2.2/dashboards.js. For more on each installation method, see the installation guide.

Impact

The data cursor keeps its listener and state bookkeeping in plain objects keyed by data table id, so a table id of __proto__ supplied in the dataPool connector configuration resolves to Object.prototype when a sync registers its listeners, and the registration creates a property on Object.prototype named after the sync state and holding the internal listener array. The property name begins with a state prefix fixed by the library, to which the sync group option can append an attacker-chosen suffix, and its value is the library's own listener array, but the property is enumerable and visible on every object in the page, and emitting a lasting state for that table id then throws, so syncs that keep lasting states, such as extremes, stop working. Exploitation requires that untrusted data reach the Dashboards configuration and that a sync such as highlight or extremes be enabled on a component using that table, which the same configuration can do. No user interaction is required beyond loading the board.

The injected property is inert until other code on the page reads or enumerates it, so consequences depend on the consuming application.

Affected versions

@highcharts/dashboards (>= 1.0.0, <= 4.2.1)

Security releases

@highcharts/dashboards → 4.2.2 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade @highcharts/dashboards to 4.2.2 or later to resolve this vulnerability.

Kodem Kai can prioritize this vulnerability in your dependency tree and generate a fix recommendation.

Frequently Asked Questions

  1. What is CVE-2026-118243? CVE-2026-118243 is a medium-severity security vulnerability in @highcharts/dashboards (npm), affecting versions >= 1.0.0, <= 4.2.1. It is fixed in 4.2.2.
  2. Which versions of @highcharts/dashboards are affected by CVE-2026-118243? @highcharts/dashboards (npm) versions >= 1.0.0, <= 4.2.1 is affected.
  3. Is there a fix for CVE-2026-118243? Yes. CVE-2026-118243 is fixed in 4.2.2. Upgrade to this version or later.
  4. Is CVE-2026-118243 exploitable, and should I be worried? Whether CVE-2026-118243 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  5. What actually determines whether CVE-2026-118243 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  6. How do I fix CVE-2026-118243? Upgrade @highcharts/dashboards to 4.2.2 or later.

Other vulnerabilities in @highcharts/dashboards

Stop the waste.
Protect your environment with Kodem.