CVE-2026-7700

CVE-2026-7700 is a high-severity code injection vulnerability in langflow (pip), affecting versions >= 1.3.0, < 1.10.3. It is fixed in 1.10.3.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Langflow: Prompt injection in Langflow Smart Transform can lead to code execution

Langflow versions 1.3.0 through 1.10.2 contain a code-injection vulnerability in the Smart Transform (LambdaFilterComponent) component.

Smart Transform places flow-author instructions and a preview of its input data into a prompt asking an LLM to generate a Python lambda. It then extracts a one-line lambda from the model response, applies only syntactic format checks, evaluates it with Python's full builtins, and invokes the resulting function inside the Langflow process.

A malicious flow author can exploit this directly through the Instructions field. In deployments where an exposed flow passes attacker-controlled content into Smart Transform, an attacker may also exploit it indirectly through prompt injection, subject to the configured model following the injected instruction.

Vulnerability details

Vulnerable Code Location: src/lfx/src/lfx/components/llm_operations/lambda_filter.py (line 242 in v1.10.2)

def _validate_lambda(self, lambda_text: str) -> bool:
    """Validate the provided lambda function text."""
    return lambda_text.strip().startswith("lambda") and ":" in lambda_text

# ...
return eval(lambda_text)  # noqa: S307

For example, an attacker can attempt to make the model return:

lambda x: __import__("os").system("id")

This expression satisfies the vulnerable format checks. eval() creates the lambda with access to Python's default builtins, and the subsequent fn(data) invocation (in _execute_lambda) executes the command.

Successful exploitation allows code execution with the privileges of the Langflow service process. This can expose or modify credentials, files, application data, and network resources accessible to that process, and may affect other tenants in shared deployments.

PoC

https://github.com/user-attachments/assets/13c48fe1-7225-4e0d-9687-2d2df1e87f0e

Workarounds

Until an upgrade is possible:

  • Remove Smart Transform from runnable flows.
  • Restrict flow creation, editing, and execution to trusted users.
  • Do not route untrusted or externally controlled data through Smart Transform.
  • Limit the Langflow process's filesystem, network, and credential access.

Credit

  • Peyton Kennedy (p80n-sec) of Endor Labs, reporter (original finder)
  • SZXSec, reporter (duplicate report)
  • cyjhhh, reporter (duplicate report)
  • 0gur1, reporter (duplicate report)
  • ajm4n, reporter (duplicate report, Finding 1 of a multi-finding submission)
  • andifilhohub, analyst
  • Jordan Frazier (jordanrfrazier), remediation developer

Impact

Untrusted input is evaluated as executable code within the application's runtime environment. Typical impact: arbitrary code execution within the application's privilege context.

CVE-2026-7700 has a CVSS score of 8.8 (High). The vector is network-reachable, low privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (1.10.3); upgrading removes the vulnerable code path.

Affected versions

langflow (>= 1.3.0, < 1.10.3)

Security releases

langflow → 1.10.3 (pip)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

The reported path was addressed by validating the generated code's AST and evaluating it with a restricted builtins mapping.

The mainline fix is in PR #13530 (1641b28f) and shipped in Langflow 1.11.0. The 1.10.3 backport is in PR #14071 (94859df3). Users should upgrade to Langflow 1.10.3 or later.

Frequently Asked Questions

  1. What is CVE-2026-7700? CVE-2026-7700 is a high-severity code injection vulnerability in langflow (pip), affecting versions >= 1.3.0, < 1.10.3. It is fixed in 1.10.3. Untrusted input is evaluated as executable code within the application's runtime environment.
  2. How severe is CVE-2026-7700? CVE-2026-7700 has a CVSS score of 8.8 (High). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of langflow are affected by CVE-2026-7700? langflow (pip) versions >= 1.3.0, < 1.10.3 is affected.
  4. Is there a fix for CVE-2026-7700? Yes. CVE-2026-7700 is fixed in 1.10.3. Upgrade to this version or later.
  5. Is CVE-2026-7700 exploitable, and should I be worried? Whether CVE-2026-7700 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-7700 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-7700? Upgrade langflow to 1.10.3 or later.

Other vulnerabilities in langflow

Stop the waste.
Protect your environment with Kodem.